Back to overview
Downtime

Sparkle is unusable.

Jun 19 at 04:38pm CEST

Resolved
Jun 19 at 06:24pm CEST

Sparkle is back!

Created
Jun 19 at 04:38pm CEST

Sparkle has been taken offline. There was a fault in our system. Sorry about this. If you have problems after the downtime, send us a email: info@nheards.com