Back to overview
Downtime
Service Disruption Alert
Dec 05 at 09:32pm CET
Affected services
Nheards Classic
Resolved
Dec 05 at 09:46pm CET
The site is back operational!
Affected services
Nheards Classic
Updated
Dec 05 at 09:36pm CET
We found the error, this will be fixed after 5-10 minutes. Thanks for waiting and using Nheards!
Affected services
Nheards Classic
Updated
Dec 05 at 09:35pm CET
Helpdesk is back online.
Affected services
Nheards Classic
Created
Dec 05 at 09:32pm CET
We're aware that Nheards is currently experiencing technical issues, rendering the platform offline. Our team is working hard to fix this. Your patience is appreciated as we resolve this disruption.
- The Nheards Team 🛠️
Affected services
Nheards Classic