Back to overview
Degraded
Ads not showing
Jul 09 at 02:05pm CEST
Resolved
Jul 09 at 03:11pm CEST
Normally is it working right now. Thank you for waiting and using Nheards.
Affected services
Created
Jul 09 at 02:05pm CEST
Ads cant display on the site.
Affected services